Back to overview
Some services are down
Sep 15 at 12:59am CET
Affected services
API
Resolved
Sep 15 at 12:59am CET
MTN was unstable at the moment, There were be long delays when processing mobile money orders.
Affected services
Resolved
Sep 15 at 12:59am CET
MTN was unstable at the moment, There were be long delays when processing mobile money orders.
Affected services